T Nation

Weed Eater Won't Idle Help Please

Okay so my mom has a Poulan 1500 weed eater. Like the smallest one they make. I got a new carberator from Amazon and installed it. Pump the bulb, full choke pulled tried to start, choke off pulled again fires right up and runs like a charm.
It just won’t idle. You can ease the pressure off the throttle and it will stay running but the minute you let go it dies. It will start back up if you go through the choke on choke off thing and runs.

I tried adjusting the idle screw but nada.

Any ideas?

Fuel filter if there is one, and fuel lines, though I’m sure that if you changed the carburetor that you also changed the lines and filter.

I’d also look at any spark arrestors and the general condition of the exhaust, to make sure that it is in good condition and operating as designed.

Yep, new lines, filter, spark plug, air filter and gasket. Brand new fancy gas. The exhaust will be my next thing to check. Thanks!

Dirty spark plug?

No, brand new. Starts fine ànd runs fine.

Is it one that you have to mix oil and fuel or separated.
It can be too much oil. Either in the mix or it inject too much.

Yes it’s two cycle, but I buy the pre mixed gas. 40:1.

That stuff is so nice for around the house. I use it too for my chainsaw (infrequently) and weed wacker regularly. It keeps well and runs well.

Just fired up the chainsaw yesterday after it has been sitting for like 8 months and it only took like 5 pulls.

1 Like

I give up. I would say the problem is the red color.
I am very sold to my orange power tools.
My bf has a poulan chain saw and she is a picky bitch. My beloved Stihl never bucks.
I would not turn down an Husqvarna.
But that is just me.:rofl: l love those toys way too much.

1 Like

I understand I have Stihl too. I gave up on Poulan a good while ago. My mom is 78 and this is a feather lite so it’s easier for her to start and use. We got her a new one last year and it’s still heavier. Just trying to make an old lady happy.
It’s got to be something simple. It starts right up and runs great.

I was cleaning my Husqvarna yesterday and the manufacturing stamp says 1997.

So it’s officially old enough to drink.

I really like Stihl too. That’s all I’ve used in commercial work. I used my husq for a couple of years commercially, but it has mainly been my personal side job/home/emergency tool.

We have a small 80 acres of land. We need commercial grade.
My tractor is also an orange Kubota :wink:

1 Like

:astonished:
Small 80 acres?

1 Like

Your new carb should have an idle adjuster screw. Try adjusting that, as it might need to be different than the factory position. That is what I would do, based on what you have done already.

1 Like

I have already tried that, still no luck.

Okay, first, are you sure that the choke is actually fully releasing? sometimes they stick a little, as do new needle valves sometimes. Check the air filter too, it might even be interferring with the butterfly depending on the setup and such.
Side note from a tool addict that did contracting:
Husqvarna and Poulan are the same company. Husqvarna is the Commercial level stuff and Poulan is the Homeowner grade. Both were owned by Electrolux, and Partner was the Heavy Commercial/Industrial grade, Husqvarna/Poulan was spun off into a separate company a few years back. They also make stuff for Makita and several other power toolcompanies that don’t do their own version of a gas poweredpiece of equipment.
Stihl is, was, and will always be the best. Period. I’ve used them all in vintages from the 60’s to the 2000’s. Stihl is king. And it doesn’t hurt that orange is my favourite colour.

1 Like

Choke is releasing, butterfly valve is wide open. Air filter is just a small piece of foam set in a plastic frame. Won’t idle with or without the filter in place.

Could be the needle valve but I think it would be running poorly if it were not getting enough gas. No lag, no loading, seems to be running great.

I’m going to check the exhaust as @SkyzykS has suggested and go from there.

If that don’t work I am thinking of wrapping the idle adjustment screw with some tape to hold the throttle lever back just a hair. If you keep your finger slightly on the throttle it will stay running.

That definitely sounds like the idle adustment isn’t working/right then. Is there an fuel filter inside the tank on the end of the line? Those things gum up and cause problems, especially with the ethanol gas we get now.

Yes there is a fuel filter and I replaced it too. The whole thing come together as a kit kinda deal. New carb, gaskets, filters, primer bulbs, fuel line, spark plug, all for $14… lol

I think the idle screw and throttle cable just don’t geehaw together. I cut a small piece of a drinking straw slipped it around the idle adjustment screw and got it going. The screw is either a cunt hair too small or the cable is a hair too long. Either way it’s working!

1 Like

A cunt hair as a size of measurement is something I’m going to have to use in my daily life.

1 Like