T Nation

Site has Stopped Working for in MS Edge but Comes Up Fine in Chrome

Has any one else had this issue? I’ve tried from multiple PC’s work and home.

1 Like

MS Edge is extinct as far as I’m concerned, I have been using chrome for more than a decade and never have any problems.

I am an IT manager and have customers who use all three of the major browsers on the market. I just thought that the site owner might be interested due to the fact that he excepts advertising and some of the users cannot see those advertisements. Money is on the table for someone.

I agree. Think this should’ve been opened in Forum feedback though.

Same problem. I updated Edge and it worked again. I should just take my laptop out of S mode and go back to using chrome again…

I don’t work for the site but do web development. It would be helpful to give what version of Edge your using and specify the behavior more clearly. It would also be helpful to not use Edge (at least it’s not IE), Firefox, Brave, Chrome, Safari, And even Opera are better browsers.

Holy shit, throwback.

2 Likes

It’s still a surprisingly decent and modern browser, I downloaded it because they built a VPN into it, which is kind of cool but not useful enough for me to make it my default. The interface is pretty decent though, honestly.

1 Like

Ive had the same issue for about a week. Only the third additional browser I downloaded displays the forums at all - all other stay blank.

Guess there was some sort of update? Probably worth looking into.

Microsoft Edge 44.18362.449.0

I only use Chrome, and can only open the forum in incognito since a week back.

Same here - incognito mode only (within Opera as well as Chrome).

Does this have something to do with cookie acceptance?

I’d presume so. I believe blocking them tends to throw up roadblocks on most sites.

I pretty much exclusively use Chrome and am not/haven’t had any issues. I’ll see if the tech guys can see what’s what.

Still seeing the same issue with Edge?

@Chris_Colucci I was having the same issue but its since been ‘fixed?’. It started working for me again about a week ago.

Still broken.

Forums aren’t loading for me now on Safari. Tried different networks but no joy. Works fine though on chrome.

Probably cookie related, try Safari in incognito mode.