Can't Post in Pharma/TRT Section

As of yesterday I have been unable to reply to anything within these two aforementioned categories.

Is this a mistake, or has my account been blacklisted?

If the latter is the case… why…?

1 Like

We’re working to make the Pharma and T Replacement forums log in only, but there shouldn’t be anything in place that prevents you from posting once you are logged in.

My apologies for the inconvenience, and I will look into this.


Here are two screenshots for reference

As you can see. It is not possible for me to create a new topic

And there is no option for me to reply to poats.

1 Like

Same for me. No way to reply.

1 Like

Things should be fixed now. Please reply in this thread if you’re still having issues.

1 Like

It stopped working again from mobile devices.

Hmm. I hate to ask, but have you tried logging out and back in? And just to confirm, it was working again after the initial outage?

I don’t believe any changes were made recently that should have affected this, but we will look into it.

I’ve logged out and back in, doesn’t work

Yes it worked for awhile after your first reply. Stopped tonight. I just noticed pharma is working but not the TRT subcategory.

Things should be working again, but please let me know if they aren’t.

Thanks to all for bringing this to our attention!

1 Like

I know the road to get here was “rocky” but want to take a moment and recognize the excellent changes to the Pharma/TRT forum. The new banner looks great and I like the “member” only view feature to make people do a little work to view those posts.

I don’t think I have ever done so much work to add one letter to one word (safe to safer) but I am proud of you folks and happy with result. I sincerely hope it helps give the right message.

Thanks @Mod_Phoenix @Tim_Patterson and the rest behind the scenes.

Funny…someone always has to do the work to effect change. You are all welcome! Happy to help improve the forum.